Beim Arbeiten in der Modellierungsumgebung wird in regelmäßigen Abständen die Fehlermeldung "Zugriff verweigert" eingeblendet

Symptome

Während der Arbeit in der Modellierungsumgebung für Prozesse bzw. Prozesslandkarten erscheint in regelmäßigen Abständen am rechten Rand des Browserfensters eine Fehlermeldung mit dem Titel "Zugriff verweigert" und einem sehr langen Text (vgl. Beispiel im Screenshot).

Ursache

Dieser Fehler tritt auf, wenn bestimmte Einstellungen Ihrer Firewall bzw. Ihres Proxy-Servers die fehlerfreie Kommunikation mit der PICTURE-Prozessplattform unterbinden.

Technischer Hintergrund

Die PPP sendet während der Arbeit in der Modellierungsumgebung in kurzen, regelmäßigen Abständen (mehrmals pro Minute) eine "Erinnerung" an unseren Server, damit das gerade in Bearbeitung befindliche Prozessmodell bzw. die Prozesslandkarte zur Bearbeitung durch andere Nutzer gesperrt bleibt. Diese Verbindungsaufnahme wird in Ihrem Fall von Ihrer internen Firewall bzw. Ihrem Proxy-Server verhindert und von dieser/diesem mit der obigen Fehlermeldung quittiert (der in der Fehlermeldung angezeigte Text stammt hierbei nicht von der Prozessplattform selbst sondern wird direkt von der Firewall bzw. vom Proxy-Server erzeugt und von der Prozessplattform nur zur Anzeige im Browser "durchgereicht"). Die Firewall-Regeln, die zur Unterbrechung der o.g. Verbindungen führen, liegen außerhalb unseres Einflussbereichs. 

Lösung

Wenden Sie sich mit den obigen Informationen an Ihre internen IT-Abteilung, um dieses Problem zu beheben. Diese wird in der Lage sein, anhand dieser Hinweise und der konkreten angezeigten Fehlermeldung die Konfiguration der Firewall so anzupassen, dass Sie die PICTURE-Prozessplattform wieder korrekt genutzt werden kann (z.B. durch Ergänzung bestimmter Ausnahme-Regeln für die Prozessplattform).

Sollten Sie bzw. Ihre IT-Abteilung hierzu Rückfragen haben wenden Sie sich gerne an unserem Support (support@picture-gmbh.de).